Ending support for Internet Explorer 8

On Monday, July 10, 2017, Hushmail is ending our support for Internet Explorer 8.

What does this mean?
As we continue to improve our webmail platform, some of our new features will not perform as intended on that version of the browser.

Who is affected?
Only people who use version 8 of the web browser Internet Explorer or lower.

What should I do?
If you still use Internet Explorer 8, you need to install the latest version of Internet Explorer, or another browser. We support current versions of all major browsers, such as Chrome, Firefox, Safari and Internet Explorer.

Hushmail recommends always using the latest software, including web browsers, to help maintain your security online—it’s one of our top three security tips.